Firmware patch codgev1 now available.

Support for hardware and software issues. Ask your question and (hopefully) someone will give you an answer.
Post Reply
Posts: 243
Joined: Wed Dec 21, 2011 10:53 am

Re: Firmware patch codgev1 now available.

Post by larkim »

Was just about to post to see whether this was possible!

Yes, I'm happy to do this; Winter Hill. Let me know which file needs distributing and I'll upload it tonight.

2 x 3view PVR, both on CodgeView. Winter Hill region.

Posts: 13
Joined: Sun Sep 02, 2012 8:43 pm

Re: Firmware patch codgev1 now available.

Post by sturge08 »

I live in Stafford - and I have no idea which transmitter I use.

Posts: 243
Joined: Wed Dec 21, 2011 10:53 am

Re: Firmware patch codgev1 now available.

Post by larkim »

Stafford will be served either by Sutton Coldfield or The Wrekin. You can probably tell by virtue of which way your aerial is pointing. If it is pointed about SW / WSW it will be the Wrekin, if it is pointing SE then that would be Sutton Coldfield. It seems from the maps that Stafford is in something of a black hole from Sutton Coldfield, but it would depend where in Stafford you were.

Hope this helps!

2 x 3view PVR, both on CodgeView. Winter Hill region.

Posts: 2
Joined: Sat Sep 22, 2012 7:31 pm

Re: Firmware patch codgev1 now available.

Post by Dunedin »

I have joined the Codge View party & I am delighted by the results.
I have learned lots along the way.

My experience with channel rescan has been that the process finds 125 channels but then does not terminate itself.
I have to do this manually. I am on Rowridge IoW, which has been changing recently.

Happy to copy the file & send : where to?


Posts: 50
Joined: Sun Dec 18, 2011 10:37 pm

Re: Firmware patch codgev1 now available.

Post by IWantPVR »

I'm happy to contribute and have a fully tuned box but I'm in Crystal Palace also.

User avatar
Barry The Sprout
Site Admin
Posts: 717
Joined: Fri Dec 16, 2011 9:18 pm
Location: South Coast

Re: Firmware patch codgev1 now available.

Post by Barry The Sprout »

Handy website to help you work out what your local transmitter is.

I have Whitehawk Hill data available. Will be downloading the new firmware shortly.

And one big point: patience guys. As oldcodge says above, sometimes you just need to wait for things to settle down. Wait for things to happen. Do a scan, then use the box for a bit. Let it settle down.

As to those of you getting confused - we are covering so many different topics so fast here it is not surprising you are getting confused. Stick up a few "novice question" threads or just plain ask and we will see what we can do between us.
No one on this forum has ever worked for 3View CE Ltd, we've no association with that dead company. We just own boxes like you. We're a band of hackers trying to get the hardware we have paid for to work. We are doing this for free in our spare time

Posts: 4
Joined: Thu Sep 20, 2012 9:17 pm

Re: Firmware patch codgev1 now available.

Post by Pleco »

Install went great, just sat waiting on 'scanning for channels now'...
The box is alive but seems to be doing nothing for the last hour or so.
I've not had much time to read through the thread / check I'm not doing
something obvious wrong (not unusual) but I'll sit down later and check.

I think it's 'Winter Hill' here BTW (Thanks for the link Barry The Sprout!)

Either way, the box hasn't crashed or exploded... (yet!) Cheers Mr. codge

Code: Select all

login: root
-bash-3.00# cd /tmp
-bash-3.00# cp mp0/codgev1.tar .
-bash-3.00# tar -xf codgev1.tar
-bash-3.00# ./
enabling telnet in the rescue system
xenv modified.  writing new data.   read size=3418.  write size=131072
remounting / rw
/sbin/fsck.jfs version 1.1.13, 17-Jul-2008
processing started: 9/24/2012 13.19.4
Using default parameter: -p
The current device is:  /dev/sda5
Block size in bytes:  4096
Filesystem size in blocks:  244140
**Phase 0 - Replay Journal Log
Filesystem is clean.
making backups of system files
creating dual boot files
Applying binary patches
3+0 records in
3+0 records out
44+0 records in
44+0 records out
44+0 records in
44+0 records out
44+0 records in
44+0 records out
44+0 records in
44+0 records out
mounting / ro
if you see an error here, that's OK
install completed
creating intial database backup
creating initial channels backup
update finished, please type reboot now to finish installation.

Just booted into yellow button (EPG) mode, seems to actual be scanning now...


Posts: 10
Joined: Mon Jun 11, 2012 12:28 pm

Re: Firmware patch codgev1 now available.

Post by IB1 »

I'm also now a very happy CodgeView user.

I also am in the auto "overnight epg update" camp, mainly due to the fact I will almost certainly forget to go into epg mode from time to time. Also it will help with recordings during holidays etc when the box is unattended for a while.

One thing I have noted with the patched firmware is the box now feels more responsive and the animations are smoother, I guess the now disabled functions were using a lot of processor power.

I also did a channel scan ...silly ... yes I know, it took a few go's but I've now got all the data for Emley Moor

Many thanks to Codge and everyone else for this fix.


Posts: 1
Joined: Mon Sep 24, 2012 8:02 pm

Re: Firmware patch codgev1 now available.

Post by chrish »

For those struggling with a full channel scan, after a HD format, my box would not complete a full scan. It hung after identifying approx 60 channels each time. In the end I did a manual scan from channel 50 onwards (I'm on Winter Hill where most channels are between 50 & 68) to complete the channel list. This process took about 15 mins, no hanging and it saved the channel list after each successful manual tune.

Thanks @oldcodge for all your hard work, another 3view box is brought back to life!

Posts: 12
Joined: Sat Sep 22, 2012 7:52 pm

Re: Firmware patch codgev1 now available.

Post by Ddave »

Firstly to echo the appreciation of all of us non-techies in helping us to extend the life of the PVR. A huge thank you to OldCodge for putting the patch and such thorough documentation together.
OK, so I performed the updates last night but am now stuck in the crash loop which I am unable to get out of........

My sequence of events (steps 1 & 2 performed with Aerial disconnected)
1) Update of the 3View to the latest Beta stipulated in the comprehensive instructions (using USB and 3View User Interface)
- Update successful

2) Update to the OldCodge Patched version
- Update successful, box booted with the new 'CodgeView' splashscreen (nice touch btw). I was feeling very chuffed at this point

3) Power Removed and aerial inserted (to avoid killing tuner as recommended by BarryTheSprout in previous posts)
- Box Boots, shows the 3View splash screen, then enters crash loop
- Held down the blue button on remote in case this is the crash documented in the 'getting out of trouble' section - No change (not sure when the remote becomes active, ie, if button is pressed too early would the instruction be ignored?), tried holding for the duration of the reboot, regular long presses (5-10sec in duration throughout reboot cycle) then pressing & holding later in the reboot cycle to no avail?

4) Removed power, aerial & network, replaced power and cold restart performed, crash loop continued. repeated steps with the blue button, no change.

OK, so I believed that I had done something wrong as the steps would not get me out of the EPG mode crash, therefore found instructions on entering Maintenance mode (holding in standby on box during a cold restart) to reload the original firmware

In maintenance mode, when reloading the "simply8654t2_trunk_37956-1_201108211726" file (same download/USB stick used to update box). The copy progress stays at 0% until the box announces the failure??

At this point I gave up and decided to request the aid of far more knowledgeable group in the morning (yourselves). Note, I also left the box rebooting overnight in case the box did finally stay up (as mentioned in the workaround section of the instructions).
- Unfortunately, the box was still happily restarting this morning when checked.

What did I miss?

Apologies in advance if I have missed an instruction or step.

Post Reply